Creating Webpages in Dreamweaver MX for Mac

Getting Started
Before you can create a webpage you need to think about where the page will be stored both lo-
cally (i.e., hard drive, CD, disk) and remotely (i.e., webserver). If you don’t know where the remote
site is located, you can add this later. You'll want to store all your documents in the same folder or
directory. Let’s open Dreamweaver and setup your site.
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To setup your site: == —r—————
Open Dreamweaver MX. = el e —
A new Untitled document will appear. T et
Or, you may need to click Create. S —
Pull down the Site menu, select New Site. i
Enter a name for your site such as your name. T i s s e
Click the small folder icon to browse. e
Locate your folder or make a new folder. - -
Name the folder a single, short word.
For example, use your last name. i A s
Be sure to remember the folder’s location. L~ 2
Click Choose. e S
A site map will pop up. et Do s innte
Close this site map window.
If you know the website name, enter it.
Click Remote Info in the left column.
Enter the FTP information, if available.
This is used to upload your files to a web server.
Click OK. s o)

Setting Up Your Document

Before entering content, we need to set up the page. This includes giving the document a title,
saving the page, and inserting a table and cells. The table provides the overall structure for the
page. The cells provide a space to write and insert pictures.

Title : {Untitled Docurment |

To give the document a name:
Click in the area next to the word Title. [8 b e i i et St o e e en

Remove the words Untitled Document. e e R e

Enter a title for your document. i :
This title can be long or short. It will appear in
the title bar of your web browser. For example,

you might name it The Wonderful World of... s

To save the document:
Pull down the File menu, select Save.
Locate your folder.
Enter the name index.html = T Dy o
This will be project’s home or core page. = =
Click Save. STe A BSOS RIRBS .
The document name and file name will appear in the title bar.




To insert a table:
Click the Layout tab and the Layout View option.

[ mmﬂr‘-[ I Ex 4 5 FamsEs
Click the Draw Layout Table option from the Object bar. e € M Ve ] Yabdes | rammes |

o Lapour view |
Click and drag from the upper left to the lower right o '\l A qJ '—T—l
corner of the document. Draw Layout Tatl)|e !
A gray box with a green border will appear on the screen. Insert Table Draw Layout Cell

The Layout Table Properties box should appear. If not,  Draw Layer
pull down the Window menu, select properties.
Enter the fixed width of 600.

Set the height to 600 to start. D =] E::t,i?: —— ,ij e — % e
Press the Enter or Return key.
The table should resize. This width allows the oldest computers to view your web page.
To insert a cell:
Click the Draw Layout Cell option from the Object bar.
Click and drag from the upper left to the lower right
corner of the document. MEB s m— 5]
A white box with blue borders will appear. ey e [ 8 1 8 I
el - !
To resize a cell:
Click on the blue border to make the handles appear.
Drag from a handle on the corner or center of the
border line.
To move a cell: e Bae L 3| ;'.' [ .lll'll" ]
Drag from the border line, not the blue border handle. e o
Or, use your arrow keys to move. Code View
Split View
Click the correct button to move between Code View, split screen, \ | Design View
and Design View: /
Y
Inserting Text
The next step is to add text. This includes setting the font, type size, style, and formatting. Setting
the font for the web is different than a word processor. The web browser has control over the text
appearance, you just provide guidelines.
To insert and format text:
Click in a cell and type some words. You can also copy and paste text from other programs.
Drag over the text to select it.
The Text Format Properties window should appear.
If not, pull down the Windows menu, select Properties.
Change the font by choosing from a short list of options.
Choose a font size from 1 to 7. Size 2 is standard. Size 3 is good for headings.
Choose formatting such as left, centered, or right. Or, bullets, number list, indent, or outdent.
You can also choose standard formats such as Paragraph, Heading 1, Heading 2, etc.
© Format [ None 18 A [arial, Hetvetic: (3] size 3 (3] W #rroooo =H888 %
Link @ 'EB' L_; Target ? £l —




Inserting Visuals

The next step is to add visuals to your project such as clipart and photographs. First, you need to
locate visuals. You may want to use clipart from websites. Be sure to get permission to use the
visuals or copy them only from public domain sources. Second, be sure that your pictures are
saved in your web project folder. Third, make certain that they are in the .GIF or .JPG format. If
you copied the visuals from the web, they are already in this format. If you used a digital camera,
they are probably .JPG files. Fourth, consider the resolution and size of the picture. You only need
visuals that are 72 DPI (dots per inch). Higher resolutions take more space and don’t increase
quality. Also, check the size. A visual that is

much more than 200 plxels high or Wide Wlll I=I.-I : ;l'll'lﬂl.l-ll File Edii WView e Boddy  Tesr Commards S Wisdoes
. | Bargfe Lireik s Wora Dl Wkl p [Derspison | e Bev =

takes too long to load. If your pictures are too B3 B W b BE Caill i
large or the wrong file format, you'll need to D adn ¥aer an

. . .- e
convert them to this format before proceeding. T
You can use a graphics package, shareware, or a Lindp o Tobs
web imaging package such as Fireworks or iy

Image Ready to prepare the visuals.

To import images:

Click in the cell where you wish to place the T _—_—_—_—_ i
pictur. Mk
Pull down the Insert menu, select Image. o i e = i
Locate the image in your folder, click Open. LB Sl weifom B
Remember, the image should already be \
in the same folder as the web page document. The picture should appear in the cell.

If you wish your picture to be right or left aligned, click the photo and choose Align from the
Image box.

Creating the Webpage Information Area

Books have title pages to provide basic information about the book. On a webpage, this informa-
tion usually goes at the bottom of the screen under a horizontal line. You should include the date
the page was created and updated as well as the author’s name. Also include an email link.

Winseri m Lasyzui r Tt r Takdna rrrirnll _rl-a-rr“ 1 Tamglatsy I

To insert a horizontal line: SR AT Y I Yl

Pull down the Insert menu, select horizontal rule.
Or, click the Common Tab on the Insert bar. Click the horizontal rule.

To add an email link: © Format [ Paragraph Iﬂﬁg Arial, Helvetic: @

Type the author’s name and the creation date. Link | mailto:alamb@eduscapes.com @
Drag over the author’s name to select it. : //

The Text Format Properties window should be open.
If not, pull down the Windows menu, select Properties.
Type the word mailto: and the email address of the author into the Link box.
You can also click on the arrows next to Link and the words will appear.
Press the Enter or Return key.
The words you selected should turn blue and underlined showing the new link.
Or, click the Common Tab on the Insert bar. Click the envelope.



Adding Web Links

You may want to link to other websites. Although you can type the address into the Link area, it’s
best to copy the address from your web browser and paste it into the link space to avoid typos:

To add a web link: Link http:/Atipt3. utaledo.edu @

Enter and select the word or words you’d like to make a “hot”.
Click in the Link area on your Text Format Properties Window.
Type the web address (URL) or paste the address. Be sure to include the http://
Press the Enter or Return key.
The words you selected should turn blue and underlined showing the new link.

Previewing the Page I @ O < {} =

You’'ll want to check the webpage in the web browsers.
To preview the page:
Pull down the File menu, select Preview in Browser, choose a Browser.

Creating Multiple Pages

Your project may involved multiple pages. If so, you need to make the pages, then link them to-
gether. You may also want a navigation area or buttons. First, let’s make additional pages. Second,
let’s link between pages. Third, let’s create some interactive pictures. If you'd like a button bar
along the top, bottom, or side of your page, you'll need to create the graphic or graphics.

To make additional pages:

Pull down the File menu, select New.

memti | R0 W sohenewy (O ] T
Add a title to the document. — s |tk g beeegen, G0 | e b

. ey wipasn | | Tag m‘ Sk [0 ‘.‘=|
Create a table (600 width). s o (0 13 e (s a1

Create cells as needed. Enter text and grapiucs. LIIEL dUUIVL/ WEDSILE HILULIAUOIL
Create a navigation line across the top or bottom of the page.

A nagivation line might look like: | Teaching | Research | Services | Home |
Save the document.

To create a local link:
Select the text you wish to make a hyperlink.

Enter the name of the file in the Link area of the é a ”
Text Format Properties Window.

Press the Enter or Return key. A L
The text should become blue and underlined. e

= e
o e)

To create navigation buttons:
Insert the graphic.
Click on the graphic to select it.
Click next to Link in the Image Properties Window.
Enter or select the name of the file.

To create a graphic map: e —
Insert the graphic. [x] OJOES
Use down arrow in the lower right corner of the Image Properties Window to expand options.
Use the shape tools and draw an oval, rectangle, or shape over the hot area.
Click in the Link area, remove the # sign, and enter the file name or URL.
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Faculty Templates
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Copy the Faculty Templates onto your computer or Zip Drive.
Or, copy them from the web at http:/ /tipt3.utoledo.edu/ tools.html

Open Dreamweaver.

Pull down the File menu, select Open, select one of the faculty folders and documents.

Modify documents as needed.

Dreamweaver Templates

Dreamweaver comes with a number of templates.

To use templates:
Open Dreamweaver.

Pull down the New menu, select Page template from the left side of the screen.

Choose a template.

Pull down the File menu, select Save As...
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Cascading Style Sheets
If you plan to have many web pages, it's a good idea to use a Cascading Style Sheet (CSS). A CSS

will help you maintain consistency by creating named styles that

you can reuse. ¥ Design =
j.css.sp,du.] HTML Styles | Behaviors |
To create a new Style Sheet: @ apply styles () Edit Styles
Pull down the Window menu, select CSS Styles. FdNo Css Style

The Design menu will appear with CSS Style selected.
Click the New New CSS Style button.

Enter the name of your first style such as mybody.
Click OK. Attach Style Sheet

Add Styl
Give the Style Sheet a name such as mystyle. | ye
Save it in your folder with your web pages. i

You need to remember to upload this document with
your web pages and images.

Choose the Font, Size, Style, etc. you wish e L35 oyl -
to apply to this style such as mybody. Name: [mybody 111 ok )
Click OK. = :
Your styles will appear on the list. Type: @ Maks Custom St (cluis) e
_ Hedefine HTML Tag
_ Use CS5 Selector
Define in: @ | mystylecss r
I This Document Only ( wep )
C&% Sawie Delingion for  myBady in mysivle.cus 5]
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To use a CSS:
Create the text in your document. Highlight (select) the text.
Choose the style from the Design menu.
Or, click the style button on the Properties menu, then select a style such as mybody.
g Format | Paragraph Fﬂx)r mybody I-G-] Arial BII %
@O0 Tage g -
To edit a CSS:

Pull down the Window menu, select CSS Styles, double-cick on the style.
Make your changes, click Apply, click OK.
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Insert Menu

0| ~ winsert [ Common [Layout] Text | Tables | Frames [ Forms | Templates | Characters | Media [ Head | Seript | Application] i
‘ i Standard View | @ =

Tool Bar
Code View File Management
Split View Preview in Browser
Design View Reference
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